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1 Introduction 

The WinScope program has been created to increase the ease of use of ALFAMATIC tools and to 

extend their potential. 

By linking the tool to a computer where WinScope is installed, we gain the following advantages: 

- Extension of the number of works available and the possibility to file them. 

- Possibility to change the working parameters by simply dragging the objects shown on the 

screen. 

- Display of the curve on the computer screen, with the possibility to save and analyse it. 

- Statistical analysis of data. 

- Filing of data in a database. 

- Display of the speed chart. 

1.1 Values and unit of measure 
The sizes used in the program are force (or reaction) expressed in decaNewtons [daN], distance (or 

movement) expressed in millimetres [mm] and speed expressed in millimetres per second [mm/s]. 

The values always use the decimal point and not a comma. It is possible to change the number of 

decimal figures from the working properties. 

1.2 Program installation 
The installation procedure copies the program from the removable discs to the hard disc inside the 

computer. 

It is possible to install WinScope freely on as many computers as you like. 

The installation procedure is also necessary when upgrading the program to a newer version. 

If you wish to install the program, follow the procedure indicated below, otherwise skip the whole 

chapter.  

� Insert the installation disc supplied with the tools into the drive of the computer; 

� Run Winscope6 on the installation disc: 

 

� Follow the instructions that appear on the screen. 

1.3 Program upgrade 
To upgrade WinScope, simply install the new version without removing the previous one. This 

maintains all the settings of the previous version. 

1.4 Backup 
The information saved on the disc inside the computer is not safe; a failure could lead to the loss of 

the files containing information. Therefore it is very important to make a frequent copy of the files 

on an external disc.  

The information is memorised in different types of file, as described in paragraph 1.6.  The most 

important are the work files, which contain all the settings necessary to the correct operation of the 

tool. The production data files and curve files are not indispensable for working, but may be 

important. 
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1.5 Backup tool configuration 
If WinScope is in Italian, it is possible to make a backup of all the values contained in the tool. Not 

all versions of the tools are supported by this function. Contact Alfamatic to request the adaptation 

for compatibility with your version. 

1.6 Types of file 

WinScope uses three types of file:  

ICON EXTENSION DESCRIPTION 

 
.qpr 

These files contain the settings of the entire work (limits, distances, 

scale, options, etc.). 

 

 
.pes 

These files are used for statistical calculations and contain the 

information relating to production. 

 

 
.prv 

These files contain working curves.  
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2 Use of the program 

This chapter guides the user in learning about the basic operations of the WinScope program. 

2.1 First start-up 

To start the program, proceed as follows (Figure 1): 

� Click the Start button to display the start menu; 

� Select All programs; 

� In the programs  menu, click WinScope6 in the WinScope folder. 

 

 
Figure 1 
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When starting WinScope, the main window containing two menus only opens: 

 

Figure 2 

The file menu enables the creation of a new job or to open previously saved files to read them, 

change them or send them to the machine. 

The Connection menu activates the connection between computer and machine. To make 

connection automatic, see paragraph 2.4. 
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To place the program in communication with the machine, select the machine from the Connection 

menu. If the machine is connected via serial port or Ethernet port, you must first add it to the list of 

ports available for use in the WinScope preference (File > Preferences): 

 

Figure 3 

If the machine is connected via serial port, click the Add serial button and select the correct 

communication port in the window that appears. 

After opening a file, creating a new job or activating the communication, a new window is 

displayed in WinScope, with the majority of the space occupied by the white area of the chart 

(Figure 5). This area usually displays the curve movement-force of the parts processes. There are 

two windows in the chart area (paragraph 2.1.1) which contain the values measured and the result 

of the curve displayed. The dots visible inside this area represent a grid. Inside the chart there are 

two rulers with numbered notches, the name of the size displayed and the unit of measure. Above 

the chart area there is a title bar indicating the name of the curve, the name of the job and, when 

connected, the name of the machine. The status bar is under the chart area. 
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Figure 4 

In the right part of the status bar there are icons indicting the type of tool and whether or not it is 

communication.   

For example  indicates that the job displayed is destined to the CSQ-Visual tool which is 

not connected. 

In this example  the communication with CSQ-Visual is active (the curve acquired will 

be shown). 

2.1.1 First experience 

Let’s try out the program now: the first thing to do is physically connect the computer to the tool. 

To do so, consult the tool manual. 

After connecting the computer to the tool, start WinScope and select the machine in the Connection 

menu. If the machine is not present in the connection menu, consult paragraph 0. 

If the connection is made successfully, the program will upload the work parameters in use from 

the tool and display them on the chart. If we start the machine to do a job, the relative curve will be 

displayed on the chart.  If the curve is not shown, regulate the scale of the chart, selecting Chart > 

Calculate scale.  To improve visibility of the chart, access its properties. 

2.2 Information windows 
It is possible to display the windows containing the values measured and the result of the active 

curve on the chart. To change the windows, use the Display > Change information windows 

command. If you wish to temporarily hide the windows, press F2 on the computer keyboard. 
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2.3 The password 
It is possible to define a password using File > Password, to prevent the work being changed by 

unauthorised persons. It is also possible to hide the menus used to change the works using File > 

Preferences. 

 

2.4 Activate communication when starting WinScope 
It is possible to configure WinScope to enter automatically into communication with the machine 

when it is started. To do this, select the Preferences command from the file menu. 

Activate the Connect automatically option in the preferences window and select the machine you 

wish to connect from the list immediately below. 

 
Figure 5 

 

2.5 Printing 
It is possible to print the chart using File > Print. 
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When this command is selected a window offering the possibility to select various printing options 

will appear: 

 

Figure 6 

Here is a description of the most particular options: 

Title and subtitle 

The title and the subtitle are two lines of text which are printed at the top of the page. They 

enable the printing of a brief description. 

Page margins 

These indicate the size of the empty margins of the page to be printed. 

Print the curves of the group on separate pages 

By activating this, a single curve per page is printed, together with the job. 

The Character buttons can be used to change the style and size of the text. 
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3 Managing the curve 
The curves are traced in the movement-force chart, if you wish to save them, you must do so one by 

one, or activate the automatic save option (chapter 4.1). By regulating the origin and the scale of 

the chart using the Chart properties, it is possible to improve the display of the curves.  

3.1 Curve group 

Usually, when a new curve is displayed, the old one is eliminated. When the Curve > Create curve 

group option is activated, it is possible to avoid eliminating the old curves and so create an 

overlapped curve group. In the curve group, one curve is the active curve and it is traced in a 

different colour (see Figure 7); it is possible to change the active curve using the Curve > Next 

curve and Previous curve commands, or the  Ctrl+P and Ctrl+S buttons. When the cursor is used 

(chapter 3.2), the values measure will be referred to the active curve.  

 

Figure 7 

1. Active curve 

2. Group of curves 

3. Cursor 

4. Point (force: 543daN) 

5. Force at the point 

6. Position at the point 

3.2 The cursor 
Using the cursor we can measure the force of the active curve in any position (see Figure 7). To do 

this, we must ensure that the chart is a movement-force chart, then move the cursor  above the 

horizontal ruler and keep the left-hand button on the mouse pressed. After a few moments, a 

vertical line will appear on the chart and the exact spot at which the cursor is found and the force of 
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the active curve measured in the cursor position will be indicated on the status bar. If we move the 

mouse to the right or left, keeping the left button pressed, we will see the values on the status bar 

change. If we also press the shift button on the computer keyboard, and move, keeping the left 

button on the mouse pressed, we will see the distance from the point in which we pressed shift to 

the current position on the status bar. 

3.3 Saving the curves 
Using the File > Save curve with name command we can save the active curve on the hard disc to 

file it or analyse it later.  

Using the File > Save curve with name command we can save all the curves of the group displayed 

in an equal number of numbered files. Subsequently, using the File > Save curve with name 

command, we can save only the new curves acquired. 

Lastly, we can activate the automatic saving of all the curves or only those of the good pieces or the 

reject pieces, as described in paragraph 4.1. 
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4 Works 

The tool parameters can be added, eliminated or changed using WinScope. 

When the connection with the machine is active and the changes have been made to the work 

settings, these will be automatically sent to the tool, when the start of a new job is requested. To 

send the change manually, use the File > Send work to the machine command. Some work settings 

are used only by WinScope and these will be saved on the computer disc when the work is sent to 

the machine. 

The work objects shown on the chart can be changed by dragging them or via access to the menus. 

When several windows are open, before changing the work using the menus, ensure that the one 

required is active. 

4.1 The work properties 
It is possible to change the work properties with the Word > Properties command. The properties 

window is divided into datasheets. 

 
Figure 8 

General 

On the general datasheet it is possible to change the name of the work and the phase, and 

activate certain options. The Setup button enables the choice of the unit of measure and the 

number of decimals in the values.  

Automatic saving 

We can decide whether or not to automatically save the curves of all the pieces, only the good 

piece or only the reject pieces. Every time a curve is detected, if the automatic saving option is 

activated, it will be saved in a file in the position and with the name specified in the window. 

The name of the file must have no extension, and may contain Tags. If no Tags are included in 
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the name of the file a progressive number will be added. With the Tags it is possible to create 

the name of the file on the basis of the work values. The following Tags can be used:  

<L> is replaced with the name of the work 

<C> is replaced with the code of the piece 

<I> is replaced with an index id the file to be saved is already present 

<P> is replaced with the progressive number of the piece. 

Archive management 

From this datasheet it is possible to archive the values measured. Note that, when a new work 

is created in the tool, the work created will have no archive management and will be 

configured on an individual basis. To avoid this, follow the instructions in chapter 4.2. 

There are three possibilities for archiving data: 

• file compatible with WinScope only, known as production record. This file contains the 

values measured in the jobs performed and can be used to perform the statistical 

analysis using WinScope. 

• database compatible with Microsoft Access.   

• CSV file. A text file containing the values measured separately, separated by 

semicolon. In this case too it is possible to configure the program to decide which 

values must be saved in the file. The name of the CSV file may contain Tags. With the 

Tags it is possible to create the name of the file on the basis of the work values. The 

following Tags can be used:  

<L> is replaced with the name of the work 

<C> is replaced with the code of the piece 

<I> is replaced with an index id the file to be saved is already present 

<P> is replaced with the progressive number of the piece. 

If for example the name of the file is “C:\Dati.csv”, all the values measured for the jobs will 

be added, one line for each job, to the same file. If the file used is “C:\<C>.csv” , all the 

values measured will be saved in single files. Every file will have its own name to match 

the piece code. 

 

4.2 Creating an identical copy of a job 
To create a copy of a job and consequently save all the settings of the management of the archives, 

proceed as follows. 

• Connect to the tool with the job to be copied. 

• Save the job to copy on the disc. 

• Disconnect the tool using the Close command from the File menu. 

• Open the newly saved job to be copied. 

• Select the Enter command from the File menu. 

• Indicate the univocal name of the job. 

This will add an identical copy of the job, with the relative WinScope settings, to the tool. 

4.3 Limits and thresholds 
On the chart, parameters such as stop values of limits are displayed as horizontal or vertical lines.  

All these parameters can be changed in the WinScope Work menu. 

If we move the cursor above a line, the line changes shape as shown the Figure below: 
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After a few seconds, the parameter name and value appear. 

During the dragging movement, the value of the current position is shown on the status bar of the 

window.  

If the mouse is right clicked, the contextual menu appears, allowing the elimination of the 

parameter or changed to the properties. 

4.4 Check points 
Every check point is defined by a position and by two minimum and maximum limit values. In this 

case too, the check points can be changed by dragging or from the WinScope Work menu. 

4.5 Analysis points 
It is possible to establish points in which to measure and analyse the value of the curve at a given 

height. These values are saved in the production record. They can be seen in the information 

windows and be filed. 

To create an analysis point, select the Work > force analysis points > Management of analysis points  

command 

To create an analysis point in a precise position, click the ruler to see the cursor (paragraph 0), 

move it to the point required, release the mouse and select the Work > force analysis points > Add force 

analysis point command. 
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5 Statistical Analysis 

With WinScope it is possible to carry out a statistical analysis of the force values measured in a 

point. 

The force values to be analysed can be taken from the tool production archive, from a file with the 

production record previously saved on disc, or from a group of curves visible on the chart in 

WinScope. It is also possible to analyse the good pieces only or all the pieces saved (Figure ). 

 
Figure 9 

5.1 The production record 

In the work properties it is possible to activate the saving of a file containing the production record. 

 
Figure 10 
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When WinScope is connected to the tool and the job for which we have activated the saving of the 

record is in use, the values of the curves we are going to create are saved. 

The values are saved only when WinScope is connected to the tool. 

Only force values measured at the force analysis points are saved (chapter 5.4).  

If a force analysis point is eliminated, the relative force values will no longer be saved. 

It is possible to display the record using the View history of group of curves in the View menu. 

 
Figure 11 

5.2 The group of curves 
When several curves are displayed on the chart at the same time, a group of curves is created. The 

statistical analysis on a group of curves can be carried out on the forces measured at any point. 

5.3 Force analysis points 
For the statistical analysis, it is necessary to have previously saved the force values in a specific 

point. In the Work menu it is possible to add points in which to measure forces for the pieces 

subsequently processed. 

5.4 Performing the statistical calculation. 
After selecting the source of data to be analysed as indicated at the beginning of the chapter, it is 

necessary to indicate the points in which to measure the force values. 


